logo

pubspec.yaml Version Issue

language-logoFlutter

• Flutter 앱 개발 중 Firebase 패키지를 최신 버전으로 업데이트하려 했으나, 의존성 문제로 인해 버전 해결에 실패함.
• web 패키지 버전을 업그레이드하려 했으나, 이는 Dart SDK의 버전을 강제로 업그레이드해야 하는 위험을 수반함.
• 문제 해결을 위해 GitHub의 과거 커밋을 참조하여 pubspec.yaml 파일을 원래 버전으로 복구하려 했으나 동일한 에러 발생.
• Firebase 관련 패키지를 주석 처리 후 Pub Get을 실행하고 다시 주석 해제하여 Pub Get을 실행함으로써 문제를 해결함.

thumbnail
북마크
공유하기
신고하기
5분 분량
조회수 117
profile-image나정민
2달 전
Copyright © 2024. Codenary All Rights Reserved.